Software that Supports SHA-2 Encryption

Support for SHA-2 has improved over the last few years. Most browsers, platforms, mail clients, and mobile devices already support SHA-2. However, some older operating systems such as Windows XP pre-SP3 do not support SHA-2 encryption.

We encourage users running older, less secure systems to upgrade.

This page lists the minimum version required for SHA-2.

Browser SHA-2 Support

Browser Minimum Browser Version
Chrome26+
Firefox1.5+
Internet Explorer6+ (With XP SP3+)
Konqueror3.5.6+
Mozilla1.4+
Netscape7.1+
Opera9.0+
Safari3+ (Ships with OS X 10.5)

Operating System SHA-2 Support

Operating System SSL Certificate Minimum OS Version
Android2.3+
Apple iOS3.0+
Blackberry5.0+
ChromeOSyes
Mac OS X10.5+
WindowsXP SP3+
Windows Phone7+

Above information is excerpted from Digicert.com 

eHelp eHelp

Minimize

3 ways to connect

Connect using either
Instant Messaging, Phone, or via Email.

Instant Messaging

Phone

909-621-8174
or
800-630-8893

Email

You should receive an E-mail confirmation within 1 hour of submitting a request.

If you do not receive an E-mail confirmation, please contact the Help Desk again:

helpdesk@cgu.edu


Staging Enabled